input delay/lag when using my keyboard

Question

I'm having a problem with input delay/lag (for lack of a better word) when using my keyboard (Razer Blackwidow X Tournament Edition) and volume control on my headset (cloud 2), after I press a key it's taking 2-3 seconds to respond. It starts happening randomly (from what I can tell) after I turn my computer on sometimes it takes 4 hours of use to happen or 10 minutes resting my computer makes it stop but it eventually comes back. Both items worked fine in a friends system and I've been unable to find a reason online any ideas?

Comments

  • leafflatleafflat Posts: 628
    edited November 16
    Is your os installed in a spinning disk hard drive?

    What are the specs of your computer.
    S[340]Blind:  Link to YouTube video.
    i7-4770
    MSI Z97s Krait
    Deepcool Captain 120 White AIO
    16gb RAM
    Asus Strix Gtx 1080


  • leafflat said:
    Is your os installed in a spinning disk hard drive?

    What are the specs of your computer.
    its on a SSD
    https://au.pcpartpicker.com/list/kdHtPs
  • leafflatleafflat Posts: 628
    edited November 16
    I would try the following things:
    Try changing the sata slot your ssd is plugged into the motherboard.
    Check power settings for the hard drive.
    Do an error check on your ssd.
    Try unplugging your 2tb HDD.
    Are you sure your not thermal throttling?
    Try dialing back your overclock.
    Try removing one of the sticks of ram, if it still happens, remove the other.
    Is there enough airflow overs your VRM heatsinks? Touch them to see if there hot to the touch.
    If you have an extra hard drive, even spinning disk drive and install windows on it to see if the same thing happens. It might be that your windows is corrupted. 
    Which version of windows are you running?

    S[340]Blind:  Link to YouTube video.
    i7-4770
    MSI Z97s Krait
    Deepcool Captain 120 White AIO
    16gb RAM
    Asus Strix Gtx 1080


Sign In or Register to comment.