Weird X58 boot issue

JacobHint(Egg)JacobHint(Egg) Posts: 3
edited December 2017 in Hardware Specific
Hey seeing as Tech Yes City does so many builds with X58 motherboards I'm kinda hoping i can get an answer to this issue i am having.

So i have this ASRock X58 Extreme 6 motherboard with an i7 970 6 core processor, i bought these new 6 or 7 years ago, have served me well and got a nice 4.2Ghz overclock on the cpu, have done plenty of upgrades over the years on it, new graphics cards, SSD's and more ram.

The problem I am having is that when i first got my 500GB Samsung EVO SSD it worked fine on the SATA 3 controller with my motherboard, running windows 7 it would boot no issues and I also did the upgrade to windows 10 on it and that booted fine too, however recently I re built the system and now it wont boot into windows off the SSD (windows 7 or windows 10).

What is happening is if i have the windows 7 CD in the DVD drive it will boot as long as CD is first boot option and i just let it time out instead of hitting a button to boot from CD, then it boots fine from the SSD for either windows 7 or windows 10, however if i have no CD in the drive no matter what boot options i choose (boot from SSD first e.t.c) it just gives me the no valid boot media and wont boot into windows.

Now here comes the super weird bit, if i plug that SSD into the SATA 2 controlled ports it boots no issue, and the even weirder bit, if i install windows 7 or windows 10 onto the mechanical 2TB HDD and have that connected to the SATA 3 controlled ports it boots no issues at all.

Basically this issue only happens with SSD's that have windows installed on them running on the SATA 3 ports, and previously they worked fine, its only been an issue since i did the re build of my system, i have tested with both my samsung SSD and my crucial SSD and they both have the same issue.

I have seen a few posts on other forums of people having the same issue but couldn't find any with an actual solution, any help would be wonderful.
Tagged:

Comments

  • leafflatleafflat Posts: 632
    Were you booting the CD in legacy? is it writing all the partinions?
    S[340]Blind:  Link to YouTube video.
    i7-4770
    MSI Z97s Krait
    Deepcool Captain 120 White AIO
    16gb RAM
    Asus Strix Gtx 1080


  • nevernevernevernever Posts: 8
    edited December 2017
    Do not use the sata 3 port on your x58. It's marvel and it sucks.
  • leafflat said:
    Were you booting the CD in legacy? is it writing all the partinions?
    The CD isnt the issue, that works fine, so does normal HDD's its only SSD's that have the issue, and even doing a complete clone of the mechanical HDD onto an SSD wont work, seems to be some weird issue with SSD's and the only work around if you want the SSD to boot when on SATA3 is to have the windows CD in the drive but not actually hit the button to boot from it.

    Tried every single compatibility mode i could find in the bios but nothing seems to work, just have the SSD on one of the SATA2 ports right now as it boots fine when installed to them.

    The thing that is doing my head in is that it DID work originally and is only after doing a fresh re install of windows 10 did i get the issue, and its not just windows 10 either same issue on windows 7.

    doesn't make a huge difference i guess, as nevernever said, the marvel controller used is pretty dodgy it only ends up being a little bit faster than the SATA2 ports on the board, still would love to know whats gone wrong though.
Sign In or Register to comment.